Scheduled maintenance is currently in progress, downtime has ended, verification is underway.
Posted Jan 10, 2026 - 09:47 GMT
Update
Scheduled maintenance is currently in progress. Planned downtime has now started.
Posted Jan 10, 2026 - 09:42 GMT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 10, 2026 - 09:00 GMT
Scheduled
We will be undergoing scheduled database maintenance during this time. Whilst we expect any downtime to be quick it could extend to 2 hours. The Workiro application will be unavailable during this maintenance window. Thank-you for your patience.
Posted Jan 09, 2026 - 16:42 GMT
This scheduled maintenance affected: Workiro Web App and Workiro Connect.